cc(4) FreeBSD Kernel Interfaces Manual cc(4)
cc -- Modular congestion control
The modular congestion control framework allows the TCP implementation to
dynamically change the congestion control algorithm used by new and
existing connections. Algorithms are identified by a unique ascii(7)
name. Algorithm modules can be compiled into the kernel or loaded as
kernel modules using the kld(4) facility.
The default algorithm is NewReno, and all connections use the default
unless explicitly overridden using the TCP_CONGESTION socket option (see
tcp(4) for details). The default can be changed using a sysctl(3) MIB
variable detailed in the MIB Variables section below.
The framework exposes the following variables in the net.inet.tcp.cc
branch of the sysctl(3) MIB:
available Read-only list of currently available congestion control algo-
rithms by name.
algorithm Returns the current default congestion control algorithm when
read, and changes the default when set. When attempting to
change the default algorithm, this variable should be set to
one of the names listed by the net.inet.tcp.cc.available MIB
cc_chd(4), cc_cubic(4), cc_hd(4), cc_htcp(4), cc_newreno(4), cc_vegas(4),
Development and testing of this software were made possible in part by
grants from the FreeBSD Foundation and Cisco University Research Program
Fund at Community Foundation Silicon Valley.
The cc modular congestion control framework first appeared in
The framework was first released in 2007 by James Healy and Lawrence
Stewart whilst working on the NewTCP research project at Swinburne Uni-
versity of Technology's Centre for Advanced Internet Architectures, Mel-
bourne, Australia, which was made possible in part by a grant from the
Cisco University Research Program Fund at Community Foundation Silicon
Valley. More details are available at:
The cc facility was written by Lawrence Stewart <lstewart@FreeBSD.org>,
James Healy <email@example.com> and David Hayes <firstname.lastname@example.org>.
This manual page was written by David Hayes <email@example.com> and
Lawrence Stewart <lstewart@FreeBSD.org>.
FreeBSD 9.0 February 15, 2011 FreeBSD 9.0
Man(1) output converted with